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Getting Started with the Intelligent Mail® Barcode 
  

Applies to: SmartMailer™ 
 

Purpose 
This document provides instructions on how to start using the Intelligent Mail® barcode (IMb) in your 
SmartMailer™ mailings. Using Intelligent Mail® barcodes will be required as of January 28, 2013 if you 
wish to obtain USPS® automation discounts. 
 

About the Intelligent Mail® Barcode 
The Intelligent Mail® barcode is a 65-bar USPS barcode that is used to sort and track letters and flats. It 
offers more accurate and detailed information about your mailings. 
 
Unlike the POSTNET™ barcode, which only contains the delivery point ZIP Code, the new Intelligent 
Mail® barcode contains additional fields such as Service Type Indicator, Sequence Number, and Mailer 
ID. These fields expand your ability to number your mail so that you can uniquely identify each mail piece, 
track individual pieces, and provide greater visibility into the mailstream. To use the Intelligent Mail® 
barcode, you must populate the additional fields when setting up your mailing in SmartMailer™.  
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The Intelligent Mail® barcode became available for use as an option in 2006, but will be a mandatory 
requirement for USPS automation discounts in January 2013. The USPS will no longer allow the 
POSTNET barcode to benefit from USPS automation discounts.  

 
The Intelligent Mail® barcode replaces the functionality of several barcodes into one, including multi-
service code, ACS™, POSTNET™, and PLANET®. The new requirements cover mail piece barcodes 
and new barcodes for tray labels, sack labels and container placards (pallets, rolling carts, etc.). 
 
Overall, the Intelligent Mail® barcode has been designed to use USPS services, new applications, and 
future benefits, all inclusive in one barcode. 

Procedures 

Overview 

Here is a brief overview of the procedures for setting up and using the Intelligent Mail® barcode in 
SmartMailer™: 

1. Obtain a Mailer ID from the USPS®. 

2. Enter your new Mailer ID in SmartMailer™. 

3. Create your Intelligent Mail® barcode mailing (including the TrackMyMail option) in SmartMailer™. 

4. Add the Intelligent Mail® barcode to your mail piece layout using Envelope Designer™ Plus. 

5. Print your mail list, selecting the mail piece layout you created and saved in step 4. 

- OR – 

Export the mail list from SmartMailer™, selecting the Export Intelligent Mail® Barcode data checkbox in 

the Export Wizard. 

6. If you selected the Full Service using Postal Wizard or Mail.XML option (in Procedure 3) or if your post 

office requires electronic documentation, you must use the USPS® Business Customer Gateway Postal 

Wizard® or submit via Mail.XML. 

 

These steps are explained in greater detail in the remaining sections of this document. 
 

 

NOTE: The information contained in Procedure 1: Obtain a Mailer ID from the USPS® is a reproduction of 

content provided in the USPS® web site (reproduced with permission). 
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Procedure 1: Obtain a Mailer ID from the USPS® 
 

Steps to Obtain a Mailer ID for New Mailers 

This document provides a very high level overview of how new commercial mailers can obtain a Mailer ID 
for automation-price mailing using the Intelligent Mail® barcode. Information includes: 

 Accessing the Business Customer Gateway 
 Registering as a New User 
 Noting the Customer Registration ID (CRID) 
 Requesting a Business Service 
 Assigning a Business Service Administrator (BSA) 
 Obtaining a Mailer ID 

For more detailed information, refer to the User Access to Electronic Mailing Information and Reports 
Guide (referred to in this document as the “Guide”) available on RIBBS® at 
http://ribbs.usps.gov/index.cfm?page=intellmailguides 

 
 

NOTE: The screen shots may vary from the actual web site due to ongoing enhancements to the portal! 

 

Accessing the Business Customer Gateway 

 

On the USPS web site, click on the Business 

Customer Gateway link, located under the 

OTHER USPS SITES column in the bottom 

right hand corner of the web page. 

 
 
 
 
 
 

Registering as a New User 

 

1. On the Business Customer Gateway login 

page, click New User Registration 

located in the Login section. 

 

 

 

 

 

 

 

 

http://ribbs.usps.gov/index.cfm?page=intellmailguides
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2. Pick a username, 

password and two 

security questions.  

 

 

 

 

 

 

 

 

 

3. Enter contact and 

company 

information. 

 

 

 

 

 

 

 

 

 

 

4. Read the Privacy Policy and 

click Create Account. 

 

 

 

Noting the Customer Reference ID (CRID) 

Customer Reference IDs (CRIDs) are automatically assigned A) when you are awarded a bulk mailing permit, or B) 
during the initial login at the Business Customer Gateway. For each unique combination of company name and 
physical address, the USPS® will create a new CRID that connects a company’s information at a specific 
geographic location across all USPS® applications. The CRID is required in order to sort using one of the Intelligent 
Mail® barcode options. To locate the CRID: 
 
1) Click the GATEWAY link 

located at the top of most 
Business Customer Gateway 
web pages.  
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2) Click the Profile link found 

under Your Account Settings. 
 
 
 
 
 
 
 
 
 
 
 
3) The CRID is located in the 

Business Locations table. 
 
 
 
 
 

 

 

 

 

 

 

 
 

For more information on CRIDs, see section 2 “Navigating the Business Customer Gateway” in the Guide. 
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Requesting a Business Service 

 

A “business service” is functionality that mailers can request access for through the Gateway. A Service must be 

authorized before access is granted. 

 

For more information on requesting a service, see section 2 “Navigating the Business Customer Gateway” in the 

Guide. 

 

Obtaining a Mailer ID 

 

1. If you are not on the Select a 

Business Service page, click the 

GATEWAY link found at the top of 

a Business Customer Gateway 

web page. 

 

 

 

2. Under the Design & Prepare 

category, click the Mailer ID link. 

 

 

 

 

 

 

 

 

 

 

 

 

3. Select checkbox next to desired 

location(s), click Next. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. Review the information, click Confirm. 
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Assigning a Business Service Administrator (BSA) 

Before selecting a service, the BSA must be identified. 

 

Unless a different person is going to be the 

primary BSA, simply: 

 Review the Terms and Conditions. 

 Acknowledge that you’ve read and 

understand the agreement. 

 Select the desired Business Name. 

 Click Yes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Access should be granted.  

 Click Continue. 

 

 

 

 

 

For more information on BSAs, see section 2 “Navigating the Business Customer Gateway” in the Guide. 

 
Obtaining a Mailer ID … continued 

You may need to go back to the Services page and click the Mailer ID link again. 

 

1. Select the desired location from the 

Business Location drop-down.  

 

2. Click Request a MID. 
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3. Use the MID Type drop-down to 

select a 6-digit or 9-digit Mailer ID. 

6-digit MIDs are reserved for large 

volume (10,000,000 pieces+) 

mailers.  

 

4. Enter a number into the Number of 

MIDs Requested. 

 

5. Click Request Mid. 

 

 

 

 

 

6. For a mailer using FULL or BASIC 

and no other services, check 

option Full / Basic Service. 

 

7. Click Request Mid.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8. The new Mailer ID is displayed.  
 

9. Click Return to Summary. 

 

 

 

 

 

 

 

For more information on Mailer IDs, see section 8 “Mailer ID System” in the Guide. 
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Procedure 2: Enter Your New Mailer ID in SmartMailer™ 
 
To enter your new Mailer ID in SmartMailer™: 
 

1) Launch SmartMailer™ in Classic Mode. 
2) In SmartMailer, select menu item Edit > Preferences or press Ctrl-R. 
3) In Preferences, click tab Intelligent Mail® Barcode. 
4) Click button Mailer Names and IDs. 
5) In Mailers, click button Create. 
6) Enter the mailer name in the Mailer Name field. 
7) Enter the Mailer ID in the Mailer ID field.  
8) Click OK, then click OK again to exit the Mailers dialog. 
9) Click OK to exit Preferences. 

 

Procedure 3: Create Your Intelligent Mail® barcode Mailing 
 
To create an Intelligent Mail® Barcode mailing in SmartMailer™: 
 

1) Launch SmartMailer™ in Classic Mode. 
2) In SmartMailer, select menu item Process Mail > Presort > Setup Wizard. 
3) Click Mail Piece Setup from the left menu. 
4) In the Barcode section, select option Intelligent Mail® barcode. 
5) Click Mailing Options from the left menu. 
6) In the Sortation Methods/Rates section, under the Automation checkbox, select one of the options. 

 

NOTE: The Basic Option is a discounted mailing that has an Intelligent Mail® barcode instead of a POSTNET™ 

barcode. A Full Service using Postal Wizard or Mail.XML mailing gives an additional $0.001 or $0.003 discount 

per piece if you submit your documentation electronically. The Full Service methods that are supported include 

Postal Wizard via the Business Customer Gateway (for < 10,000 piece mailings) or Mail.XML.  

Full Service requirements, such as unique sequence numbers, Intelligent Mail® container labels, and so on are 

handled by SmartMailer™ automatically. 

 
7) Click Origin/Entry Options from the left menu. 
8) You must now assign your new Mailer ID to a new or existing Permit Holder. 

a. Select your target permit from the Permit Holder drop-down and click Edit. 

– OR –  

Click New to create a new Permit Holder. 
b. In Permit Holder Information, click Select located next to the Mailer ID field. 
c. In Mailers, select the target mailer from the Mailer Name drop-down and click OK. 
d. Update any information as required in the Permit Holder Information, then click Save. 

9) Click Mailer ID Selection from the left menu. 
10) Select the mail owner from the Mailer Owner drop-down. 
11) Continue setting up your mailing in the Presort Setup Wizard. 

 

IMPORTANT: If you plan to create a tracking job after the sort is completed, a TrackMyMail Mailer ID will be applied 

to your mail pieces – not the new Mailer ID you obtained in Procedure 1. This happens automatically when you 

create a tracking job. Note, however, that your Mailer ID will be applied to the container labels. For more information 

about setting up and including the TrackMyMail option, refer to the SmartMailer™ Help. 
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Procedure 4: Add an Intelligent Mail® Barcode to your Mail Piece 
Layout in Envelope Designer™ Plus 
 
To add an Intelligent Mail® barcode to your mail piece layout: 
 

1) Launch Envelope Designer™ Plus (ED+). 
2) Select menu item Edit > Barcode. 
3) Select Barcode Type option Intelligent Mail® Barcode. 
4) Select the desired location from the Barcode Position drop-down. 

 
5) If you are using Envelope Designer™ Plus in standalone mode (that is, if you are launching it 

outside of SmartMailer™), it will accept the input for Intelligent Mail® barcode contents in one of 
several formats. 

a. Click Setup to display the Intelligent Mail Barcode Setup dialog (see below). 
 

NOTE: If the Setup button is not active, select menu item File > Attach to Mail List to choose a mail list that 

contains Intelligent Mail® barcode data. 

 
b. Select one of the setup options: 

All the barcode information is in this field: 

– OR – 

Barcode information is specified below: 
 Tracking information field: 

– OR – 

 The tracking information is specified below: 
 

c. Further configure the selection option as required. For more details and help with any of 
these options, click its More Info button. 

d. Click OK to save and exit to the Barcodes dialog. 
 

6) Click OK to save and exit to the main (layout) window. 
7) Remember to save the layout (File > Save or File > Save As) before exiting the application. 

Figure 1 – ED+ via SmartMailer Figure 2 – ED+ (standalone) with list attached 
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Procedure 5: Print Mail Pieces or Export SmartMailer™ Mail List 
Intelligent Mail® barcode Mailing 
 
Print the mail pieces for your list, making sure you select the Intelligent Mail® barcode layout you created 
and saved in Envelope Designer™ Plus. (See Procedure 4 in this document).  

– OR – 

If you prefer to export addresses from the mail list to a different file type for use in another application, 
export the mail list from SmartMailer™. Make sure you check option Export Intelligent Mail® Barcode 
data in the Export Wizard. 
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Procedure 6: Submitting Postal Documentation Electronically 
 
You will need to submit postal documentation electronically if you selected the presort Automation option 
of Full Service using Postal Wizard or Mail.XML or if your local post office requires it. You can do this 
by launching the Presort Reports dialog from SmartMailer™ (File > Print > Reports > Presort Reports). 
 

NOTE: Electronic submission of postal documentation for automation discounts is not required until January 2014. 

 
SmartMailer™ supports two methods for submitting postal documentation electronically; Postal Wizard® 
and Mail.XML®. 
 
Postal Wizard®: 
For mailings of fewer than 10,000 pieces, you can submit electronically using the Postal Wizard®.  
 
Click Postal Wizard from the Presort Reports dialog to launch 
your browser to the USPS® Business Customer Gateway and 
display the Postal Wizard Sequence Numbers dialog. This 
dialog has information you will need when you use the USPS® 
Customer Gateway Postal Wizard®. You can copy and paste 
from this dialog.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Mail.XML®: 
The Mail.XML® feature is available only for discounted mailings. It allows you to connect to the 
PostalOne! web site and transmit information about your presorted mailing to the USPS®. Once 
processed by the USPS®, the acceptance procedure (when you bring your mailing to the post office) will 
be simpler and quicker. 
 
Before using this new feature, you will be required to open an account at the USPS® Business Customer 
Gateway and take a series of simple tests to ensure you are ready to submit a live mailing. See document 
Getting Started with Mail.XML® in SmartMailer™ located on the SmartMailer™ DVD for more details.  
 
Click Mail.XML from the Presort Reports dialog to display the Submit Mail.XML to PostalOne! dialog.  

 Verify that it says PostalOne! Production at the top of the dialog. If not, go to the Mail.XML tab in 
Preferences and select option Production. 

 Enter a meaningful job name. It will appear on the dashboard in PostalOne! after you submit. 

 Enter your username and password (both are case sensitive).  

 Click Submit to PostalOne!.  
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 After a few minutes, you will see a Submission 
Successful message. Click Close to return to the 
Presort Reports dialog.  


